Alors, petit article qui va en rĂ©alitĂ© couvrir 3 sujets : l’utilisation du service DHCP sous Windows, le routage avec l’utilisation de routeurs Cisco pour effectuer la liaison entre les diffĂ©rents rĂ©seaux, et certainement le plus important, la mĂ©thodologie Ă  adopter pour arriver Ă  une bonne configuration.

Pour rĂ©ussir ce tuto (ou TP comme vous voulez), munissez-vous d’une feuille et d’un stylo ! Oui oui vous avez bien lu ! mail 

Pour faire un bon professionnel de l’IT, l’une des qualitĂ©s principales (« c’est d’ĂȘtre feignant ! », « qui a dit ça ?! ») c’est de pouvoir schĂ©matiser, visionner ce qu’on veut obtenir. Les configs c’est avant tout dans la tĂȘte ! wacko


Mettre en place un relais DHCP

Info + : Pour en savoir plus sur le protocole DHCP, consultez cet article : Introduction au DHCP

Le but de ce tutoriel sera de faire en sorte qu’un serveur DHCP dĂ©livre des adresses IP Ă  deux rĂ©seaux diffĂ©rents sĂ©parĂ©s par un routeur Cisco.

Info ++ : L’article va mettre l’accent en grande partie sur l’aspect mĂ©thodologique afin de rĂ©ussir Ă  bien ce projet. Se jeter directement dans les configurations comme un furieux sans rĂ©flĂ©chir en amont n’est jamais une bonne mĂ©thode 😉

L’infrastructure rĂ©alisĂ©e dans le cadre de cet article a Ă©tĂ© construite sous vmWare Workstation et le simulateur GNS3 afin d’utiliser de façon plus proche de la rĂ©alitĂ© les diffĂ©rents Ă©lĂ©ments qui la compose (machines virtuelles Windows et routeurs Cisco). Vous pouvez Ă©galement la rĂ©aliser sur Packet Tracer.

Voici la topologie que nous allons construire :

0. Configurer mentalement l’infrastructure cible

Je commence volontairement par le chapitre 0, l’étude et la rĂ©flexion sur le projet final. Qu’est-ce qu’on a, qu’est-ce qu’on veut avoir et comment procĂ©der pour l’obtenir ? Et bien Ă©tudions laugh (La feuille et le stylo c’est maintenant
)

Nous avons bien 2 réseaux physiques distincts :

    • Le rĂ©seau A : 192.168.10.0/24
    • Le rĂ©seau B : 192.168.20.0/24

Dans un 1er temps, nous allons Ă©tablir l’adressage IP que nous voulons mettre en place. Je vais faire ça sous forme de tableau dans lequel je vais rĂ©pertorier mes Ă©quipements et leurs ports (uniquement ceux que nous allons utiliser) qui devront avoir une adresse IP fixe :

Matériel/port Adresse IP Masque Passerelle DNS
BOX – Gi0/0 AttribuĂ©e automatiquement par DHCP externe (IP Public)
BOX – Gi0/1 192.168.10.1 255.255.255.0
Routeur Gi0/0 192.168.10.2 255.255.255.0
Routeur Gi0/1 192.168.20.1 255.255.255.0
Serveur DHCP 192.168.10.10 255.255.255.0 192.168.10.1 8.8.8.8

Les switchs sont uniquement passifs (hub), aucune configuration n’est nĂ©cessaire.

Je complĂšte mon schĂ©ma rĂ©seau et voilĂ  la topologie complĂšte de ma future infra, avec l’adressage IP :

 

Ensuite je réfléchis à la configuration de mon service DHCP. Voilà ce que je sais :

  • J’ai 2 rĂ©seaux donc, j’aurais 2 Ă©tendues.
  • Je dĂ©cide que les plages d’adresses Ă  attribuer iront de la 100 Ă  la 200.
  • Le bail restera sur la durĂ©e par dĂ©faut, 8 jours.
  • Je n’ai qu’un seul serveur DNS pour tous les rĂ©seaux ayant pour IP 8.8.8.8 (DNS de Google).
  • Mes 2 rĂ©seaux ont des passerelles diffĂ©rentes.

Je vais donc définir mes étendues comme ceci :

Le DHCP, c’est fait !

 

Ensuite, qui dit 2 rĂ©seaux physiques diffĂ©rents, dit
 ROUTAGE !

La BOX et le routeur vont avoir besoin de routes pour relayer correctement les paquets. Pour connaütre ces routes, il faut tout simplement se mettre à la place d’un paquet et faire le chemin !

Regardons de plus prĂšs pour le rĂ©seau B. Comment faire en sorte que mes postes clients du rĂ©seau B accĂšdent au reste du rĂ©seau de l’entreprise mais aussi Ă  Internet ?

Si un paquet part du PC du rĂ©seau B Ă  destination d’une adresse IP sur Internet, il sera envoyĂ© Ă  la passerelle du rĂ©seau B, Ă  savoir l’interface Gi0/1 du routeur.

Mais comme le routeur ne connait pas l’adresse de destination puisqu’elle n’est pas dans ses rĂ©seaux connus Ă  lui, il va devoir transfĂ©rer le paquet Ă  un autre routeur (ce qu’on appelle le “saut suivant“). L’autre routeur, dans notre cas actuel, c’est la BOX.

Il faudra donc dĂ©finir ce qu’on appelle une “route par dĂ©faut” Ă  notre routeur. Une route par dĂ©faut est dĂ©finie par le rĂ©seau 0.0.0.0/0. Remplissons un tableau de routage :

Equipement RĂ©seau de destination Masque de destination Saut suivant
Routeur 0.0.0.0 0.0.0.0 192.168.10.1

Ici, ce qu’on dit plus prĂ©cisĂ©ment au routeur, pourrait ĂȘtre traduit textuellement par : « Peu importe oĂč tu veux aller, passe par l’adresse 192.168.10.1 »

Attention petite prĂ©cision, le saut suivant d’une route doit toujours ĂȘtre accessible, c’est-Ă -dire dans le mĂȘme rĂ©seau que l’une des pattes du routeur !

Passons Ă  la table de routage de la BOX.

Si un paquet arrive Ă  destination d’une adresse sur internet, la box saura dĂ©jĂ  qu’elle doit le transfĂ©rer Ă  son saut suivant grĂące Ă  l’attribution automatique de son adresse IP Publique. En revanche, la BOX ne connait pas le rĂ©seau B, elle ne pourra donc pas rĂ©pondre aux postes clients de ce rĂ©seau !

Il faut donc lui dĂ©finir une route Ă  destination du rĂ©seau B, en lui indiquant qu’elle doit passer par le routeur.

Si vous avez compris le concept du routage, vous devriez en avoir déduit la table de routage suivante pour notre BOX :

Equipement RĂ©seau de destination Masque de destination Saut suivant
Box 192.168.20.0 255.255.255.0 192.168.10.2

 

Maintenant que nous avons couchĂ© sur le papier la configuration de notre infrastructure, il ne reste plus qu’Ă  l’appliquer ! 

Info ++ : Les Ă©tapes effectuĂ©es jusqu’à prĂ©sent ne sont pas Ă  nĂ©gliger. Il est trĂšs important de prendre le temps de faire un schĂ©ma, mĂȘme grossier, de ce que l’on souhaite et de dĂ©finir son adressage IP en amont ! Une fois toutes ces informations claires, la configuration en sera d’autant plus simple et rapide.

 

1. Configurer la Box Internet

L’équipement que j’ai appelĂ© ici BOX, n’est en fait tout simplement qu’un routeur NAT, « Network Address Translation », c’est-Ă -dire une passerelle faisant le lien entre le rĂ©seau de l’entreprise et Internet. Le routeur NAT va traduire (on peut parfois entendre le terme de « translater ») les adresses IP internes, qui ne sont pas accessibles depuis l’extĂ©rieur, en adresses IP externes, routables sur internet et inversement.

Nous allons donc paramétrer la BOX complÚtement et vérifier notre travail en tentant de sortir sur internet depuis une machine dans le réseau A, à savoir depuis le serveur DHCP.

Voici l’ensemble des commandes Ă  saisir sur l’équipement BOX (dans l’ordre) et leur action correspondante :

en Passer en mode d’ “exĂ©cution privilĂ©giĂ©”.
conf t Passer en mode configuration globale
hostname BOX Renommer l’équipement
int gi0/0 Passer en mode de configuration de l’interface gi0/0
ip address dhcp DĂ©finir l’adressage IP de cette interface en mode DHCP
description WAN Ajouter la description “WAN” Ă  cette interface
ip nat outside Définir cette interface comme étant celle extérieure
no shutdown Activer cette interface
int gi0/1  Passer en mode de configuration de l’interface gi0/1
description LAN Ajouter la description “LAN” Ă  cette interface
ip nat inside Définir cette interface comme étant celle intérieure
ip address 192.168.10.1 255.255.255.0 DĂ©finir une adresse IP et un masque Ă  cette interface
no shutdown Activer l’interface
exit Quitter la configuration des interfaces
ip route 192.168.20.0 255.255.255.0 192.168.10.2 Définir la route à prendre pour accéder au réseau B
ip access-list standard NAT_INTERNET CrĂ©er une ACL (liste d’accĂšs) standard nommĂ©e “NAT_INTERNET
permit 192.168.10.0 0.0.0.255 Autoriser l’accĂšs extĂ©rieur au rĂ©seau A
permit 192.168.20.0 0.0.0.255 Autoriser l’accĂšs extĂ©rieur au rĂ©seau B
exit Quitter la configuration de l’ACL
ip nat inside source list NAT_INTERNET interface Gi0/0 overload Autoriser le routeur Ă  transmettre les paquets des rĂ©seaux dĂ©finis dans l’ACL prĂ©cĂ©dente et Ă  translater (traduire) l’adresse IP source par celle de l’interface gi0/0 (par l’IP Public)
end Quitter les modes de configurations
copy ru st Sauvegarder la configuration actuelle dans la configuration de dĂ©marrage de l’équipement

On peut contrĂŽler les adresses IP de nos interfaces avec la commande : show ip interface brief

Une fois ceci fait, on va vérifier que le réseau A peut sortir sur internet. Nous allons utiliser le serveur DHCP et lancer un ping à destination du DNS de Google : 8.8.8.8

La requĂȘte aboutie. Nous en avons terminĂ© avec la BOX.

 

2. Configurer le serveur DHCP

Avant de mettre en place un relais DHCP, nous allons déjà voir si nos clients du réseau A récupÚrent bien automatiquement une configuration IP émanant de notre serveur.

Je pars du principe que votre service DHCP est dĂ©jĂ  installĂ© et que vous savez le configurer. Si ce n’est pas le cas, tout est dĂ©taillĂ© dans cet article : Installation et Configuration du service DHCP sous Windows

L’étendue A, pour le rĂ©seau 192.168.10.0/24, a Ă©tĂ© crĂ©Ă©e comme dĂ©crite dans le tableau DHCP.

Une fois l’étendue activĂ©e, allez sur le poste client du rĂ©seau A. Lancez si nĂ©cessaire la commande ipconfig /renew

Le client a bien reçu une configuration IP du serveur DHCP. Tentons d’accĂ©der Ă  internet en lançant un ping sur google.fr.

Le ping abouti, la configuration DHCP est bien fonctionnelle pour notre réseau A.

Maintenant, il faut crĂ©er l’étendue pour le rĂ©seau B ! RĂ©fĂ©rez-vous au tableau de l’étendue B du dĂ©but d’article pour les adresses.

Nous en avons terminé avec le DHCP.

 

3. Configurer le routeur et activer le relais DHCP

Ok maintenant, on passe à la configuration du routeur situé sur nos 2 réseaux. Voici les commandes pour cet équipement :

en Passer en mode d’ “exĂ©cution privilĂ©giĂ©”.
conf t Passer en mode configuration globale
int gi0/0 Passer en mode de configuration de l’interface gi0/0
ip address 192.168.10.2 255.255.255.0  Définir une adresse IP et un masque à cette interface
description LAN-A Ajouter la description “LAN-A” Ă  cette interface
no shutdown Activer cette interface
int gi0/1  Passer en mode de configuration de l’interface gi0/1
description LAN-B Ajouter la description “LAN-B” Ă  cette interface
ip address 192.168.20.1 255.255.255.0 DĂ©finir une adresse IP et un masque Ă  cette interface
ip helper-address 192.168.10.10
Activer le relais DHCP sur cette interface en prĂ©cisant l’adresse IP du serveur DHCP afin de relayer les paquets Ă©mis Ă  sa destination (broadcast) et inversement
no shutdown Activer l’interface
exit Quitter la configuration des interfaces
ip route 0.0.0.0 0.0.0.0 192.168.10.1 DĂ©finir la route par dĂ©faut Ă  prendre pour aller sur n’importe quel autre rĂ©seau
end Quitter les modes de configurations
copy ru st Sauvegarder la configuration actuelle dans la configuration de dĂ©marrage de l’équipement

VoilĂ  qui est fait. On vĂ©rifie en se rendant sur un poste client du rĂ©seau B. On n’oublie pas de lancer la commande ipconfig /renew pour s’assurer qu’il rĂ©cupĂšre bien une adresse IP du DHCP.

Ça fonctionne ! Notre PC du rĂ©seau B a bien reçu sa configuration IP d’un serveur DHCP situĂ© sur le rĂ©seau A.

On teste l’accùs à internet en pinguant google.fr pour valider le fonctionnement du routage qu’on a mis en place :

On reçoit bien une rĂ©ponse, le routage fonctionne. On peut Ă©galement lancer un traceroute vers 8.8.8.8 pour vĂ©rifier par oĂč transitent les paquets :

J’ai coupĂ© la requĂȘte car j’avais seulement besoin de vĂ©rifier que les paquets passaient bien par le routeur et ensuite la box. C’est le cas !

 

Le Relais DHCP est opérationnel !
Nos postes des deux réseaux reçoivent automatiquement une configuration IP !

 

Pour aller plus loin, on pourrait mettre en place dans notre infrastructure de la tolérance de panne et de la répartition de charge en y plaçant un second serveur DHCP, cette fois-ci cÎté réseau B.

Je vous laisse mĂ©diter sur ce point qui ferra (peut-ĂȘtre) l’objet d’un futur article


A bientĂŽt ! hi

[Tuto] Mettre en place un relais DHCP entre 2 réseaux

Articles pouvant vous intéresser